Set up the Feathers SDK in Adobe Flash Builder

Let's get your Flash Builder development environment setup to use the Feathers SDK.

Create a new workspace for Feathers SDK projects

First, we should to create a new workspace in Flash Builder. We're going to make some changes to the workspace settings so that Flash Builder works a little more smoothly with the Feathers SDK. We don't want to do that in a workspace that contains any Flex projects.

  1. Create a new workspace in Flash Builder by selecting File menu → Switch workspaceOther....

  2. Choose a directory for the new workspace.

  3. Click OK to create the new workspace.

Don't create a new project yet! We have a couple of things to tweak first.

Add the Feathers SDK to Flash Builder

  1. Install the Feathers SDK somewhere on your computer.

  2. Open the Flash Builder preferences on Mac OS X by going to the Flash Builder menu → Preferences. On Windows, select the Window menu → Preferences....

  3. Expand the Flash Builder node on the list to the left of the preferences window, and select Installed Flex SDKs.

  4. Click the Add... button, and in the new window, choose the directory where you installed the Feathers SDK. Click OK when finished.

  5. Click the checkbox next to the Feathers SDK in the Name column to make this SDK the default for the workspace.

  6. Click Finish.

Import the file templates for the Feathers SDK

Next, we're going to import custom templates for new MXML files. The default templates provided by Flash Builder don't work with Feathers components, so these custom templates will provide the right settings.

  1. Download the Feathers SDK file templates for Flash Builder 4.6 and 4.7.

  2. Open the Flash Builder preferences on Mac OS X by going to the Flash Builder menu → Preferences. On Windows, select the Window menu → Preferences....

  3. Expand the Flash Builder node on the list to the left of the preferences window, and select File Templates.

  4. Click the Import... button and choose the file templates that were downloaded in step 1.

How to create a project for a mobile application

Let's create a mobile application that uses Adobe AIR to target iOS or Android. If you need to create a web or desktop project, skip ahead to the next section.

  1. In Flash Builder, select the File menu → NewFlex Mobile Project. A new window will open to customize the project's settings.

  2. Enter your Project name. The default Project location is usually okay. Click Next.

  3. Under Application Template, choose Blank. Do not choose one of the other templates.

  4. Click Finish.

How to create a new project for a web or desktop application

Let's create a web or desktop application that can target Flash Player in a web browser or native desktop application. If you need to create a mobile project, take a look at the previous section.

  1. In Flash Builder, select the File menu → NewFlex Project. A new window will open to customize the project's settings.

  2. Enter your Project name. The default Project location is usually okay.

  3. Select either the Web or Desktop application type.

  4. Click Finish.

Conclusion

Flash Builder can now use the Feathers SDK, and your first project is ready. If you're unsure how to proceed, take a look at the Getting Started with Feathers and MXML tutorial.

Known Issues